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 Licence Agreement 
 

 

 

Licence Agreement:  The purchaser of this software agrees to the following licence conditions.  This 

program is owned by MinServ (Mineral Services) and is protected under Australian copyright law and 

international agreements.  You, the purchaser, are permitted to use one copy of this software on a 

single computer at any given time.  If you have multiple licences then you can use as many copies as 

you have licences. 

 

Copyright:  The copyright that applies to this program is similar to any other copyrighted material (eg a 

book).  You can lend or transfer the software to another computer provided the software on the original 

computer is removed.  You cannot make multiple copies except that you may make one copy for backup 

purposes or you may transfer the software to a hard disk and keep the original disks as backup.  You 

cannot reverse engineer, modify or decompile the software in any way.  The accompanying software 

manual cannot be copied.   

 

   You may transfer your rights provided you transfer all copies of the software and manuals including 

any older versions of the software. 

 

Limited Warranty:  This software is sold without guarantee of any kind, express or implied.  No 

warranty is made regarding the profitability, suitability for a specific purpose or other benefits obtained 

from the use of this software.  If this software proves defective, MinServ (Mineral Services) agrees to 

either: 

 

                     1. replace the software 

 

                     2. refund all or part of the purchase price 

 at the sole discretion of MinServ (Mineral Services).   

 

 

Xplotter ©, 1995-2011 By Rob Kanen 

 

ISBN 978-1461171645  
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Introduction 
 

About Xplotter 

 

   Xplotter is a Windows program for plotting XY, Log, Line, Bubble, Pie, Polar, Vector, 

Ternary, Diamond and Bar Charts.  There is a range of options for customizing the 

appearance of each diagram and advanced features such as least squares curve fitting 

and a multiple document interface. 

Xplotter Features 

 

Built in Spreadsheet 

 

   Xplotter has an inbuilt spreadsheet for entering and editing data.  The spreadsheet 

reads and writes tab delimited ASCII files, compatible with most spreadsheets and text 

editors. A number of other popular formats including excel, csv, pdf and html are also 

supported. 

 

Graph Types 

 

   A set of plotting XY, Log, Line, Bubble, Pie, Polar, Vector, Ternary, Diamond and Bar 

Charts are included. All charts are available in 2D and 3D.   

 

Diagram Manipulation 

 

   Many options are available for plotting data.  A choice of symbols, labels and diagram 

title is available to customize the diagram. 

 

Printing 
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Print diagrams with all labels, titles, etc on any windows printer. Format the diagrams 

for printing, including, size, margins, quality etc. 

 

Getting Started 

 

 Xplotter requires a minimum system configuration for effective results.  The system 

requirements are: 

 

 Windows 2000, XP, Vista, Windows 7, Windows 8 

Net Framework version (V4.0 or higher) requires Net Framework 

4.0 or higher. 

 Devices supported by Windows 

 Printer supported by Windows. 

 

 For automatic installation, proceed as follows: 

 

1. Start Windows and place CD into CD Drive 

2. Go to the Run Option on the Start Menu and Click on Browse 

3. Open  (CDROM)D: 

4. Install Net Framework 4 

5. Install Xplotter 

6. After Setup has concluded, you will get a [App] Setup was Completed 

Successfully message. 

7. Go to the Xplotter Menu and right click on Xplotter. Select Properties and 

Run As Administrator. 

8. To Start Xplotter, go to the Xplotter Menu and click on Xplotter.  Enter your 

registration details in the Registration Window. 

 

   Installation will now proceed.  The user will be notified when installation is complete.  

A new Start Menu Item containing Xplotter and Xplotter HELP is created.  Click on 

Xplotter to start the program. 
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Tutorial 
 

Introduction 

 

   Xplotter has a standard Windows interface.  Before starting the exercise, Xplotter 

must be installed on the users hard drive and opened ready to use.  See Getting 

Started in the Introduction for information on how to install Xplotter.  A sample data file 

called comrie.plt is provided for use with the tutorial exercise. If Help is required, pull 

down the Help menu and select Contents. 

Getting To Know Xplotter 

 

   To load the comrie.plt data file, click the Open command button or select Open from 

the File menu.  The Open common dialog box will pop up.  Select comrie.plt in the  

xplotter/data directory.   

 

Plotting Data 

 

   Pull down the Options Menu and select Set Diagram Options. Accept the default 

values and click the Plot button.  A ternary diagram will appear on a new form.   When 

finished, click the OK button and you will be returned to the Spreadsheet window.   

 

Hint: 

               Use the toolbar as a short cut to acces some options. 
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Entering Data 

 

   Select New from the File menu to start a new data file.  Pull down the Options Menu 

and select Insert Ternary Headings.  The appropriate column headings are placed in 

the spreadsheet.  Data is entered in each cell by simply typing the value and pressing 

<enter>.  Use the scroll bars, arrow, page up and page down keys to navigate through 

the spreadsheet.  To edit a cell, press <enter> for the cell you want to edit and use the 

backspace/delete/insert keys to edit the text.  When finished editing press <enter> the 

new value will appear in the spreadsheet.  Whole rows can be inserted and deleted 

using the Insert Row and Delete Row command buttons.  Blank lines are not permitted 

between data.   Enter the following data: 

 

Sample # Quartz Al Felds Plag 

 

134223 25 20 55 

134225 12 36 52 

134226 7 56 37 

134227 47 21 32 

 

   To edit a cell, go back to Row 2, Col 1 and press <enter>.  Type 134224 to replace 

134223 and press <enter>. 

 

    When you have finished using the program, select Exit from the File menu. 

Hint: 

               If an error occurs while plotting data, the most likely cause is 

incorrect data.  Check for zero or blank data values.  Mixed numeric and non-

numeric data will also produce errors. 
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Hint: 

               Use the mouse to navigate through the spreadsheet.  Click a cell to 

change the current cell or click on the scroll bars to display out of view data.  

To begin editing a cell, double click the mouse. 
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Xplotter Menu System 
 

Introduction 

 

When Xplotter is started the first screen displayed contains a spreadsheet and menu 

system.  The menu system provides access to all the features of Xplotter.  Standard 

Windows menu items; such as, File, Edit and Help are included.  Other menu items 

provide access to the specialised features of Xplotter. 

File Menu 

 

   The File Menu provides many standard file management options. 

 

New Command 

 

   Starts a new spreadsheet. 

 

Close Command 

 

   Closes the current spreadsheet. 

 

Open Command 

 

   Provides access to the Open common dialog box.  Opens a new file.  Select the 

directory and file and click OK.  A file can also be opened by clicking the Open 

command button. 

 

 

 

Save Command 
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   Saves a file to disk.  The default filename is the current filename.  The same result is 

obtained by clicking the Save command button. 

 

Save As Command 

 

   Saves a file to disk in a directory and filename specified by the user.  A Save As 

dialog box pops up for the user to enter filename and directory path information. 

 

 Print Command 

 

   Prints a data file.  A Print dialog box pops up.  Select Print to print the file.  

 

Print Setup Command 

 

   Specifies printer settings available to the user.  A Print Setup dialog box pops up with 

several options to control the printer.   

 

Exit Command 

 

   Quits the application. 

 

 

Edit Menu 

 

   The Edit Menu provides access to several standard commands for editing the 

spreadsheet. 

 

Copy Command 

 

   Copies selected text in the spreadsheet to the clipboard without deleting.  Highlight 

the text to be copied by dragging the mouse or holding down the shift key and clicking 
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cells.  Highlighted text must be contiguous.  Select Copy to copy the selected text to 

the clipboard.  Use Paste to paste text from the clipboard to the spreadsheet.  Use Cut 

to remove highlighted text from the spreadsheet to the clipboard. 

 

Cut Command 

 

   Copies selected text from the spreadsheet to the clipboard and clears the highlighted 

area in the spreadsheet.  Highlight text to be cut by dragging the mouse or holding 

down the shift key and clicking cells.  Select Cut from the edit menu to transfer selected 

text to the clipboard.  Use Paste to retrieve cut text from the clipboard.  Use Copy when 

you want to copy text to the clipboard without deleting the highlighted text. 

 

Paste Command 

 

   Retrieves text from the clipboard and pastes it into selected cells.  Highlight cells that 

are to receive the incoming text by dragging the mouse or holding down the shift key 

and clicking cells.  Highlighted cells must be contiguous.  Select Paste from the Edit 

menu to transfer text from the clipboard to the spreadsheet..  Any text that already 

exists in the highlighted cells will be replaced.  If the number of selected cells are fewer 

than will hold the clipboard text, the rightmost text from the clipboard will be truncated 

to fit the selected cells.  If the number of cells selected exceed the length of the 

clipboard text, the remaining cells will be cleared.  Use Copy and Cut to send text to the 

clipboard. 

 

Insert Row Command 

 

   Inserts an entire row into the spreadsheet. 

 

Delete Row Command 

 

   Deletes an entire row from the spreadsheet. 
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Delete All Command 

 

   Deletes all selected rows from the spreadsheet. 

 

Search Menu 

 

    The Search Menu allows the user to find and replace user specified text. 

 

 

Find Command 

 

   Finds a user specified search text in the spreadsheet.  A pop up Search/Replace 

dialog box prompts the user for the search text.  Enter the exact search text and click 

OK to proceed with the search. 

 

Repeat Find Command 

 

   Repeats a search using the previous specified search text. 

 

Replace Command 

 

   Finds a user specified search text and replaces it with a user specified replace text.  

A pop up dialog box prompts the user for search text (Find What) and replacement text 

(Replace With).  The following options are available: 

 

             Replace- replace the first occurrence of the search text 

 with the specified replace text 

 

             Replace All - replace all occurrences of the search text 

 with the specified replace text. 

 

Sort Command 
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  The Sort Menu allows the user to sort data in the spreadsheet in numeric or 

alphabetical order. Select Sort from the Edit Menu and enter the column number to 

sort. 

Options Menu 

 

Define Columns Command 

 

   Defines which columns contain the XYZ data.  A dialog box prompts the user for 

columns containing Sample #, Symbols, Colors, X Value, Y Value and Z Value.  When 

the default data format is used, these correspond to columns 1, 2, 3, 4, 5, 6, and 7 

respectively.  

 

Insert Ternary Headings  

 

   This command selects a ternary diagram and places the appropriate column 

headings into the spreadsheet.  Axes titles can be specified in the Options Window by 

selecting Set Diagram Options. 

 

Insert XY Headings  

 

   This command selects a XY diagram and places the appropriate column headings 

into the spreadsheet.  Axes titles can be specified in the Options Window by selecting 

Set Diagram Options. 

 

Insert Diamond Headings  

 

   This command selects a diamond diagram and places the appropriate column 

headings into the spreadsheet.  Axes titles can be specified in the Options Window by 

selecting Set Diagram Options. 

 

Colors Command 
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   Provides access to the Colors dialog box for selecting the symbol colors.  Click on the 

color and click on insert to place the color code in the spreadsheet. 

 

Symbols Command 

 

   This command opens the Symbol window to view available symbols.  Click on the 

symbol and click on insert to place the symbol code number in the spreadsheet. 

 

Auto Symbols Command 

 

   Automatically assigns a symbol to each data point when a diagram is plotted. 

 

Assign Symbols Command 

 

  Automatically calculates a different symbol for set of data and places the symbol 

codes into the spreadsheet under the Symbol column heading. 

 

Convert to Coord Command 

 

   Converts modal mineralogy to XYZ coordinates as used by ternary diagrams. 

Normalize Command 

 

 Normalizes data in a specified column to a new user specified sum. 

Format Command 

 

  Automatically formats numeric data in the spreadsheet.  Specify the number of 

decimal points and click on format to format data. Formatting only occurs in columns 5 

to end. 

 

 

Statistics Command 
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  Calculates the maximum, minimum, median, mean and standard deviation of a group 

of samples.  Enter the spreadsheet column number containing the data to be analysed.  

Click on calculate to calculate statistics. 

 

Plot Menu 

Plot Bar Chart Command 

 

   Plots bar charts using data in the current spreadsheet.  The Options Window pops up 

for selecting plotting options. 

 

Plot Ternary Command 

 

   Plots ternary and diamond graphs using data in the current spreadsheet.  The 

Options Window pops up for selecting plotting options. 

 

Plot XY Command 

 

   Plots XY graphs using data in the current spreadsheet.  The Options Window pops 

up for selecting XY plotting options. 

 

Log Plot Command 

 

   Plots Log-Log and Log-Linear graphs using data in the current spreadsheet.  The 

Options Window pops up for selecting log plotting options. 
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The Spreadsheet 
 

Introduction 

 

   A spreadsheet is a form consisting of rows and columns of data and is the best 

method for displaying and manipulating data in row and column format.  The custom 

spreadsheet supplied with Xplotter is used for entering and editing data.  Once the data 

is correctly entered, data can be sorted, calculated and plotted. 

 

File Formats  

 

   The built in spreadsheet reads and writes data files in tab delimited ASCII format.  

This format is used by Microsoft Excel and is compatible with most spreadsheets.  

ASCII is short for American Standard Code for Information Exchange.  ASCII files 

contain standard text without hidden characters.  A tab delimited ASCII file is a text file 

with each field separated by a tab character and each line by a carriage return.  

Xplotter files with the .plt extension are tab delimited ASCII files. 

 

   To import a data file created with another application, save the file in tab delimited 

ASCII format (in Excel, these files have a .txt extension) , start Xplotter and open the 

data file.  Xplotter will automatically load the file into the spreadsheet.  To export a data 

file created with Xplotter, use any of the following methods: 

 

 1.  Select tab delimited ASCII format in the other application. 

 These files usually have a .txt extension.  Open the file. 

 

 2.  In Excel, the file created with Xplotter can simply be 

 opened directly. 
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  Xplotter also reads and writes Microsoft Excel (xls) and CSV files. 

.     

   Diagrams can be exported to pdf files using the pdf printer driver supplied.  Select the 

dopdf printer in the printer settings to print a pdf file. 

 

 

Entering Data 

 

      Data is entered in each cell by simply typing the value and pressing <enter>.  Use 

the scroll bars, arrow, page up and page down keys to navigate through the 

spreadsheet.  Use the scroll bars when moving around the spreadsheet.  To edit a cell, 

press <enter> for the cell you want to edit and use the backspace/delete/insert keys to 

edit the text.  When finished editing press <enter> the new value will appear in the 

spreadsheet.  Whole rows can be inserted and deleted using the Insert Row and 

Delete Row command buttons.  Blank lines are not permitted between data.  

Sorting Data 

 

   Data can be sorted numerically or alphabetically.  To sort data, pull down the Edit 

menu and select Sort.  Select a column number to sort. 

 

Converting Data to XYZ 

 

   If data has been entered as modal data, clicking on the convert to XYZ option in the 

Options Menu will convert the data to XYZ coordinates for use with Ternary and 

Diamond graphs. 
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Printing Data 

 

   Data is printed by pulling down the File menu and selecting Print.  A Print dialog box 

will pop up with several options.  Select OK to print the data.  A simple listing of current 

data will be printed. If Print Spreadsheet is selected, the spreadsheet is printed in 

tabular format. 

    

  

Hint: 

               If an error occurs in the calculation, the most likely cause is 

incorrectly entered data.  Check for zero, blank or mixed numeric and non 

numeric data. 
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The 
Diagrams 

 

Introduction 

 

   Xplotter will plot general-purpose xy, ternary, diamond, log-log and log-linear graphs.  

Many options are available to customize the diagrams.  Publication quality diagrams 

can be produced on a laser printer. 

 

Before plotting data, several options must be set to control the type and appearance of 

the diagram.  To access the Options window, pull down the Plot menu and select the 

diagrams to be plotted. 

 

Bar Chart Options Window 

 

Select Plot Bar Chart from the Plot menu to plot a bar chart. A bar chart displays 

sample numbers on the x-axis and a variable, such as Cu, Au, As etc on the Y axis. 

Bar charts have the same drawing/editing tools as the other graphs.  In the options 

window, specify a column containing the Y coordinate to plot. The X coordinate is 

automatically assigned to whatever column contains the sample # data. Choose from a 

standard bar graph or line graph. 

 

Graph titles and labels can also be entered. 
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Bubble Options Window 

 

   The Bubble Options Window sets options for Bubble plots. 

 

Bubble  

 

   Sets the method that calculates the bubble size. Autosize will normalize z data to 

make the bubbles fit on the chart. Specify radius allows the user to specify the radius (z 

data) of the bubble as a function of the Y axis scale. 

 

Set Scale 

 

   When Manual Scale is selected enter maximum and minimum values for the X and Y 

axes here. 

 

Set Titles 

 

   Enter diagram, x-axis and y-axis titles here. 

 

Plot XY or XY Setup Window 

 

   The XY Setup Window sets options for XY plots. 

 

Graph and Scale Type 

 

   Select standard XY Plot or XY Line Plot to plot points connected by lines.  Auto Scale 

or Manual Scale can be selected. 

 

Set Scale 
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   When Manual Scale is selected enter maximum and minimum values for the X and Y 

axes here. 

 

Set Titles 

 

   Enter diagram, x-axis and y-axis titles here. 

 

Vector Options Window 

 

   The Vector Options Window sets options for Vector plots. Vector Charts plot arrows, 

with an azimuth (angle) value between 0-360 degrees.  The X and Y values contain 

location coordinates and the z value contains azimuth. Symbol assignments have no 

effect on Vector plots, as only arrows are used. Colors can be assigned under the color 

column. The vector symbol can be customized using Options-Vector Symbol Menu. 

 

Scale Type 

 

   Auto Scale or Manual Scale can be selected. 

 

Set Scale 

 

   When Manual Scale is selected enter maximum and minimum values for the X and Y 

axes here. 

 

Set Titles 

 

   Enter diagram, x-axis and y-axis titles here. 

 

Pie Chart Options Window 

 

    For pie charts, it is possible to define labels and a chart title in the options window.  

Set the columns containing sample name and percentage. There are no color and 
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symbol settings for  pie charts, the built in color  library is used instead. Additional 

options can be set in the Pie Chart Window. 

 

Set Labels 

 

   This option determines which labels appear on the diagram.  Select from: 

 

 1.none - no labels appear on the diagram 

 

 2.sample name - sample names as shown on the spreadsheet 

 

Labels will be printed with the diagram. 

 

Title 

 

   Customize the chart title. 

 

Polar Chart Options Window 

 

   The Polar Options Window sets options for Polar plots. 

 

Scale 

 

   When Manual Scale is selected, enter maximum and minimum values for the Y axis 

(value data) here. Polar Charts use two variables, azimuth (or angle) and value. The 

azimuth must be 0-360 degrees.  

 

Set Titles 

 

   Enter diagram titles here 

 

Other 
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   Colors are automatically assigned to Polar Charts. User specified color and symbol 

have no effect. Line and shape drawing tools have no effect on polar charts. 

 

Plot Ternary or Diamond Options Window 

 

    The Ternary/Diamond Options window has many user definable settings to control 

the diagram. For ternary plots, data in the defined columns for top, left and right values 

are used. The default columns are columns 5, 6 and 7. For diamond plots, the defined 

column for the bottom apex is also used. The default column is column 8. For diamond 

plots, column 5 (top) and column 8 (bottom) data cannot be co-existing. Set column 5 

(top) data to empty (zero) for each entry in column 8 (bottom). 

 

Diagram Type 

 

   This option determines the type of diagram to be plotted.  Select from the list of 

diagram types. 

 

Set Labels 

 

   This option determines which labels appear on the diagram.  Select from: 

 

 1.none - no labels appear on the diagram 

 

 2.sample # - sample #'s as shown on the spreadsheet 

 

Labels will be printed with the diagram. 

 

Axes 

 

   Customize the axes labels.  Specify the axes titles here. 

 

Symbol Descriptions 
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   If you want symbol descriptions printed with the diagram, enter the descriptions here. 

 

Log Plot Setup Window 

 

The Log Plot Window sets options for Log-Log and Log-Linear Plots. 

  

Scale Type 

 

   Select log-log or log-linear type plots 

 

Scale 

 

   Select the scale of the X and Y axes here. 

 

Titles 

 

   Enter titles for the graph and x and y axes here. 

Plot Window 

 

   The Plot window displays the diagram and sends output to the printer or disk 

 
 

 

Save Diagram As Command 

 

      This command saves the current diagram in a user-specified directory and 

filename.  A pop up Dialog box appears which prompts the user for directory path and 

filename information.   The diagram can be exported to many different bitmap and 

vector file formats. Some of these include bmp, jpeg, pdf and svg. 

 

Copy Diagram Command 

 

   Copies the current diagram to the clipboard for pasting into other applications. 
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Data Information Display 

 

   Displays a data value for each point on the graph. Click on the point to display the 

data. To enable, check the Data Information Display Menu, followed by the selector 

toolbar (arrow icon). 

 

Axes Color 

 

   To change the default color of the diagram, select this command.  A Colors dialog 

box will pop up.  Select a color and click OK. 

 

Tick Marks 

 

   If this command is checked, tick marks are displayed and printed with the diagram. 

 

Print Diagram 

 

Prints the current diagram. Also previews the diagram in its fully formatted state and 

allows further control of margins, quality etc.  

 

Line Draw 

 

   To draw a line, select Line Draw.    Position the cursor where you would like the line 

to begin and drag the line by holding down the left mouse button and moving the 

mouse.  Release the left mouse button when the line is positioned correctly. 

 

Box Draw 

 

   To draw a box, select box draw.  Position the pointer where the box is to begin and 

drag the cursor by holding down the left mouse button.  Release the left mouse button 

when you have positioned the box correctly. 

 

Ellipse Draw 
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   To draw an ellipse, select ellipse draw.   Position the pointer where the ellipse is to 

begin and drag the cursor by holding down the left mouse button.  Release the left 

mouse button when you have positioned the ellipse correctly 

 

Insert Text 

 

   To insert text select Insert Text.  The cursor will change to an insertion icon.  Position 

the cursor where you would like to insert text and click the left mouse button.  Type the 

text to be inserted. When finished typing text, press f2. To edit text, click on the selector 

toolbar, then double click the text to be edited. When finished editing, press f2. To 

delete text, clear all text, press enter and F2 or Escape. 

 

Scroll Axes  

 

   Activates scrolling of the X and Y axes. Right click the mouse, with the pointer over 

the axis and drag the axis scale. 

 

Symbol Legends  

 

   Displays the selected symbol legend on screen. To add symbol descriptions, type the 

description next to the desired symbol. The symbol legend can be printed and saved. 

 

Undo 

 

    Undo the previous drawing action. 

Zoom 

 

 When zoom is selected true, hold down the right mouse key and drag the pointer from 

top left to bottom right to zoom the chart. Drag in the opposite direction to undo the 

zoom. 
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 Software Support 
   
 
 Technical support for Xplotter is provided through the pdf manual and online help. Free 

updates may be obtained using the built-in web updater program.  Downloads are also 

available at http://www.geologynet.com/download.htm. Further technical support is 

available directly from MinServ (Mineral Services); however, the software must be 

registered to receive support.  

 

MinServ (Mineral Services) 

Email: support@geologynet.com 

 Web: http://www.geologynet.com 

    

http://www.geologynet.com/download.htm
mailto:support@geologynet.com

