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 Licence Agreement 
 

 

 

Licence Agreement:  The purchaser of this software agrees to the following licence conditions.  

This program is owned by Mineral Services and is protected under Australian copyright law and 

international agreements.  You, the purchaser, are permitted to use one copy of this software on 

a single computer at any given time.  If you have multiple licences then you can use as many 

copies as you have licences. 

 

Copyright:  The copyright that applies to this program is similar to any other copyrighted 

material (eg a book).  You can lend or transfer the software to another computer provided the 

software on the original computer is removed.  You cannot make multiple copies except that 

you may make one copy for backup purposes or you may transfer the software to a hard disk 

and keep the original disks as backup.  You cannot reverse engineer, modify or decompile the 

software in any way.  The accompanying software manual cannot be copied.   

 

   You may transfer your rights provided you transfer all copies of the software and manuals 

including any older versions of the software. 

 

Limited Warranty:  This software is sold “as is” and without guarantee of any kind, express or 

implied.  No warranty is made regarding the profitability, suitability for a specific purpose or other 

benefits obtained from the use of this software. 

 

 

 

  

MinSpectra  ©, 2004-2010 by Rob Kanen, published by MinServ (Mineral Services)  
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Installation 

 

MinSpectra is supplied on a CD. To install MinSpectra on your PC follow these 

instructions: 

 

System Requirements: 

 

Windows 2000, XP, Vista, Windows 7, Server 2008 

Internet Explorer 6 SP1   

Devices supported by Windows 

Printer supported by Windows. 

 

For automatic installation, proceed as follows: 

 

1. Start windows and place CD into CD drive 

2. Select Run from the Start menu 

3. Type [CDROM]D:Disk1/Setup.exe followed by <enter> 

 

Installation will now proceed.  During installation, the user is prompted for a 

directory.  If this is ignored, a new directory called MinSpectra will be created.  If 

a directory path is entered, a new directory with this name will be created.  The 

user will be notified when installation is complete.  A new Menu Item containing 

MinSpectra is created.  Click on MinSpectra to start the program. 
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About MinSpectra 

 

 

   Minspectra is a program to display and analyze mineral spectral data.  Within 

the last ten years mineral spectral analysis via spaceborne, airborne and surface 

instruments has become widespread and is now the principle method for 

analysing and mapping minerals on a regional scale. Most existing databases 

are compiled from Thermal Em0ission Spectrometers (TES), which collect data 

in the infra-red (IR), near infra-red (NIR) and shortwave-infrared (SWIR) ranges. 

These wavelengths have proven to be the most effective for mineral 

identification. 

 

MinSpectra will display digital spectral files and also extract peaks and perform 

further analyses. Bitmap images of spectral plots can also be displayed, as 

some databases use this type of data for displaying spectral plots. A database 

menu is available for linking to external spectral databases. MinSpectra can be 

used with the Arizona State University  (ASU) rock forming minerals spectral 

database, supplied as a text file that can be loaded directly into MinSpectra’s 

spreadsheet. USGS spectral library 4a and 5a are also supplied.  Each mineral 

in USGS Spectra Library 4a consists of two files: 1: A heading file (*.txt) 

containing file information and a data file (*.spc) containing the spectral data.  

The spectra files can be loaded directly into MinSpectra. USGS Spectra Library 

5a files (*.asc) can be loaded directly into MinSpectra. 
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How To Use MinSpectra 

 

Getting Started  

 

    Sample data files are provided for initial use with the program.  To load a 

digital spectral file, select Open from the File Menu and Click on USGS 4a 

Spectra File in Filename Extension Box.  Select one of the *.spc files in the 

minspectra/USGS4a directory to plot or use your own file.  

 

Entering Peak Data 

 

   Select New from the File menu to start a new data file.  Data is entered in 

each cell by simply typing the value and pressing <enter>.  Use the scroll bars, 

arrow, page up and page down keys to navigate through the spreadsheet.  Page 

up and page down keys will display the next screen in adjacent columns.  To 

edit a cell, press <enter> for the cell you want to edit and use the 

backspace/delete/insert keys to edit the text.  When finished editing press 

<enter> the new value will appear in the spreadsheet.  Whole rows can be 

inserted and deleted using the Insert Row and Delete Row command buttons.  

Blank lines are not permitted between data. 

When you have finished using the program, select Exit from the File menu. 

 
 

Plotting a File 

 

Select Plot Scan File from the Options Menu or Click on the Plot Scan File 

Toolbar Button. The Plot Scan File Options Window will display. Select Plot from 

Spreadsheet to plot a scan file already loaded into MinSpectra’s spreadsheet. 

Alternatively, click on Browse to plot a scan file located on your hard drive. To 

plot the file, click on the Plot Button. 

 

Extracting Peaks 
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Use Extract Peaks to extract all peaks above a specified reflectance and use 

Refine Peaks Option to filter out adjacent shoulder peaks. 



 

Page | 5 

Main Menu System 

File Menu 

   The File Menu provides many standard file management options. 

 

New Command 

 

   Deletes data in the current spreadsheet to begin a new file 

 

Close Command 

 

   Closes the file displayed in the current window 

 

Open Command 

 

  The following file formats can be opened directly into MinSpectra: 

 

MinSpectra File *.msp 

Tab Delimited ASCII File *.txt 

USGS Spectra 4a Library File *.spc  

USGS Spectra 5a Library File *.asc  

JHU Spectra File *.txt 

 

  Provides access to the Open common dialog box.  Opens a new file.  Select 

the directory and file and click OK.  Files can also be opened by clicking the 

Open toolbar button. 

 

  MinSpectra Data Files Have the following Format: 

 

Line 1: “MinSpectra File” 

Line 2: Date 

Line 3: Radiation 

Line 4: Mineral Name 

Line 5: Column Headings 
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  See File Formats for more information. 

 

Import Text File Command 

 

   Imports a text file.  Select the type of file to import: 

Space Delimited 

Comma Delimited 

Tab Delimited 

Semi Colon Delimited 

Fixed Width 

Specify the number of lines to skip at the beginning of the file to avoid 

importation of file headings into the spreadsheet. 

 

Save Command 

 

   Saves a file to disk.  The default filename is the current filename.  The same 

result is obtained by clicking the Save command button. 

 

Save As Command 

 

   Saves a file to disk in a directory and filename specified by the user.  A Save 

As dialog box pops up for the user to enter filename and directory path 

information. 

 

View Image File Command 

 

Images can be viewed by selecting Add Image from the File Menu in Image 

Viewer Window. Images can be copied and pasted from the clipboard. The 

Image Viewer uses Object Linking and Embedding (OLE). The default picture 

type is a Windows Paint Image (paint.picture).  Select Add Image to add a 

frame.  Select Add Object or Add From File to load an image. The image can 

also be edited within Image Viewer using the menu.  Close Image Viewer 

Window to exit. The image is not saved. 
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Print Command 

 

   Prints a data file.  A Print dialog box pops up.  Select Print to print the file.  

Print Setup Command 

 

   Specifies printer settings available to the user.  A Print Setup dialog box pops 

up with several options to control the printer.  

Exit Command 

 

   Quits the application. 
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Edit Menu 

 

   The Edit Menu provides access to several standard commands for editing the 

spreadsheet. 

 

Copy Command 

 

   Copies selected text in the spreadsheet to the clipboard without deleting.  

Highlight the text to be copied by dragging the mouse or holding down the shift 

key and clicking cells.  Select Copy to copy the selected text to the clipboard.  

Use Paste to paste text from the clipboard to the spreadsheet.  Use Cut to 

remove highlighted text from the spreadsheet to the clipboard. 

 

Cut Command 

 

   Copies selected text from the spreadsheet to the clipboard and clears the 

highlighted area in the spreadsheet.  Highlight text to be cut by dragging the 

mouse or holding down the shift key and clicking cells.  Select Cut from the edit 

menu to transfer selected text to the clipboard.  Use Paste to retrieve cut text 

from the clipboard.  Use Copy when you want to copy text to the clipboard 

without deleting the highlighted text. 

 

Paste Command 

 

   Retrieves text from the clipboard and pastes it into selected cells.  Highlight 

cells that are to receive the incoming text by dragging the mouse or holding 

down the shift key and clicking cells.  Select Paste from the Edit menu to 

transfer text from the clipboard to the spreadsheet..  Any text that already exists 

in the highlighted cells will be replaced.  If the number of selected cells are fewer 

than will hold the clipboard text, the rightmost text from the clipboard will be 

truncated to fit the selected cells.  If the number of cells selected exceed the 

length of the clipboard text, the remaining cells will be cleared.  Use Copy and 

Cut to send text to the clipboard. 
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Insert Row Command 

 

   Inserts an entire row into the spreadsheet. 

 

Delete Row Command 

 

   Deletes an entire row from the spreadsheet. 
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Search Menu 

 

   The Search Menu allows the user to find and replace user specified text. 

 

Find Command 

 

   Finds a user specified search text in the spreadsheet.  A pop up Find dialog 

box prompts the user for the search text.  Enter the exact search text and click 

OK to proceed with the search. 

 

Find Next Command 

 

   Repeats a search using the previous specified search text. 

 

Replace Command 

 

   Finds a user specified search text and replaces it with a user specified replace 

text.  A pop up dialog box prompts the user for search text (Find What) and 

replacement text (Replace With).  The following options are available: 

 

                             Find- find the first occurrence of specified text 

 

                             Replace- replace the current text with the 

                             specified replace text 

 

                             Replace All - replace all occurrences of the search text 

                             with the specified replace text. 
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Database Menu 

 

Open External Database 

 

   Opens an external database specified by the user.  Click on the Browse 

Button to select a database program on your pc. 
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Options Menu 

Plot Scan Command 

 

   Opens the Plot Scan Options Window for plotting digital spectral files. 

 

Set Radiation Command 

 

   This command opens the radiation dialog to set the default radiation type used 

in the spectral analysis. The usual types are: 

 

VIS – Visible 

IR – Infrared 

NIR – Near Infrared 

SWIR – Short Wave Infrared 

 

Select one of these from the menu and click on OK to return to the spreadsheet. 

The radiation type is automatically saved with minspectra type tab delimited files 

(*.msp). 

 

Format Command 

 

   This command opens the format dialog to set numeric formatting of 

wavelength and reflectance.  Enter the number of decimal places to round 

wavelength or reflectance.  Select Save to save the formatting information 

without formatting the data or Format to format the data immediately. 

 

Grid 

 

   Sets the editing mode of the spreadsheet.  Select move right to enter data by 

row or move down to enter data by column. 

 

Reflectance to Percentage 
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   Converts intensity values that have been read from the spectrometer as 

counts to percentage.  Enter the upper intensity limit of the data and click on 

calculate to convert. 

 

Extract Peaks 

 

   Extracts peak intensities and wavelength values above a specified reflectance 

from digital spectral files.  Recommended to use the Plot Scan Window to 

extract peaks as this is much faster than importing a scan file into a spreadsheet 

and extracting peaks there. 

 

   Typically, extracting peaks is a two part process.  Peaks are first extracted 

from the scan file using the Extract Peaks Option.  This creates a new 

spreadsheet or table with extracted peaks.  There will be many shoulder peaks 

from the initial scan file and it is necessary to Refine and Filter the Peaks to 

obtain a final peak file.  Use the Refine Peaks Option to filter out shoulder 

peaks. 

 

Refine Peaks 

 

   This option removes adjacent shoulder peaks from the peak file.  Specify a 

range for adjacent peaks and all adjacent peaks within this range will be deleted.  

Use the recommended values if you are unsure which values to use.  Typically, 

extracting peaks is a two part process.  Peaks are first extracted from the scan 

file using the Extract Peaks Option to extract peaks above a specified intensity 

value.  This creates a new spreadsheet with extracted peaks.  There will be 

many adjacent shoulder peaks from the initial scan file and it is necessary to 

Refine and Filter the Peaks to obtain a final peak file.  Use the Refine Peaks 

Option to filter out adjacent shoulder peaks. 

 

Insert Column Headings Command 

 

   Select this option to insert standard column headings into the spreadsheet.  

Column headings will be placed in Row 1 and in the columns set with the Define 

Columns command.  Wavelength and Reflectance headings are inserted. 
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Define Columns Command 

 

   When a data file in a different format is imported , columns containing 

wavelength and reflectance must be defined using this command so that the 

calculations and plotting will be performed correctly.  Enter a column number 

between 1 and 200 in the Define Columns dialog box that corresponds to the 

data type.  If your data file contains additional data, it will still be displayed intact 

and all spreadsheet functions will work. 

 

Restore Settings Command 

 

   Select this option to restore the the recommended settings for all options. 
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Plot Scan Options Window 

 

   The Plot Scan Options Window sets options to plot a digital scan file. 

 

File Name to Plot 

 

   Click on the Browse Button to select a scan file to plot.  The following scan file 

types can be plotted: 

 

MinSpectra File *.msp 

Tab Delimited ASCII File *.txt 

USGS Spectra File V4a *.spc 

USGS Spectra File V5a *.asc 

JHU Spectra File *.txt 

Plot From Spreadsheet 

 

   Plots directly from the spreadsheet using the file loaded into the current 

spreadsheet. Specify the columns containing wavelength data and reflectance 

data. The default values are column 1 for wavelength and column 2 for 

reflectance. 

Title 

 

Enter a Title for the Scan Plot here. 
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Plot Scan Window 

 

   The Plot Scan Window displays the Scan File on screen with several options 

and controls.  The Scan File can also be printed. 

 

Axes Color 

Axes Titles 

Axes Labels 

Box Draw 

Copy Spectra 

Delete All 

Extract 

Peaks 

Fonts 

Insert 

Text 

Labels 

Line Draw 

Print 

Plot 

Refine Peaks 

Save Bitmap As 

Undo 

Spectra Color 

Spectra Size 

Spectra 

Width 

View 

Image File 

Zoom 
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Box Draw 

 

   To draw a box, select box draw.  The cursor will change to a cross hair.  

Position the cross hair where the box is to begin and drag the cursor by holding 

down the left mouse button.  A dotted box is dragged with the mouse.  Release 

the left mouse button when you have positioned the box correctly. 

Line Draw 

 

   To draw a line select Line Draw.  The cursor will change to a cross hair.  

Position the cursor where you would like the line to begin and drag the line by 

holding down the left mouse button and moving the mouse.  Release the left 

mouse button when the line is positioned correctly. 

Fonts 

 

   To change the font for inserted text select Fonts.  A Font dialog box is 

displayed with a list of available fonts.  Select a font in the list. 

Zoom 

 

   To magnify all or part of the plot click on the zoom toolbar button.  Drag the 

mouse over the portion of the plot  to be magnified.  A new window will display 

the magnified image.  

Insert Text 

 

   To insert text select Insert Text.  The cursor will change to an insertion icon.  

Position the cursor where you would like to insert text and click the left mouse 

button.  Type the text to be inserted. 

Save Bitmap As Command 

 

   This command saves the current Spectra in a user specified directory and 

filename.  A pop up dialog box appears which prompts the user for directory 

path and filename information.  The user can select a graphics file format from a 

list in the dialog box. 
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Spectra Color 

 

Select this option to change the Spectra color.  A color dialog box pops up for 

selecting the color of the Spectra.  Select a color and click OK. 

Axes Color 

 

Select this option to change the axes color.  A color dialog box pops up for 

selecting the color of the axes and axes labels.  Select a color and click OK. 

Zoom 

 

Select this option to magnify details of peaks.  Click on the Zoom toolbar button 

or select Zoom from the Edit Menu.  The cursor changes to an up arrow.  Drag 

the mouse over the peaks of interest.  A new window displays a magnified 

image of the peaks.  When finished click on the Zoom toolbar button or menu 

item to restore normal view.  The accuracy of the d-spacing and two theta 

values on the status bar depend upon the scale resolution used by the program 

and may not match precisely with the spreadsheet values.  By selecting a small 

area to zoom, for example a single peak, the accuracy is increased. 

Axes Label 

 

Select this option to change the font for the axes labels.  A font dialog box pops 

up.  Select a font from the list.  After a font is selected, click OK.  The spectra is 

plotted with the new axes labels. 

Axes Titles 

 

Select this option to change the font for the axes titles.  A font dialog box pops 

up.  Select a font from the list.  After a font is selected, click OK.  The spectra is 

plotted with the new axes titles. 

Spectra Size 

 

Select normal or small to change the default size of the printed Spectra. 

Copy Spectra Command 

 

   Copies the current Spectra to the clipboard for pasting into other applications. 
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Grid 

 

   Displays a list of data values that appear on the Spectra.  Click on a set of 

data to highlight the corresponding peak on the plot.  Labels can be plotted next 

to the highlighted line by Set Labels Command located in the Options menu. 

Print Spectra 

 

   Prints the current Spectra.  A pop up Print dialog box appears.  Click OK to 

accept the default settings and print the Spectra.  Any labels will be printed with 

the Spectra.  If peaks appear to be overlapping, select a smaller scale or use 

landscape orientation.  

Print Peak File 

 

   Prints a list of peaks that have been extracted in the Plot Scan Window 

Overlays 

 

   Imports additional scan files to plot as overlays on the original plot. Upto 4 

overlays can be plotted over the original.  

Extract Peaks 

 

   Extracts peak intensities above a specified intensity from digital scan files.  

Recommended to use the Plot Scan Window to extract peaks as this is much 

faster than importing a scan file into a spreadsheet and extracting peaks there. 

 

   Typically, extracting peaks is a two part process.  Peaks are first extracted 

from the scan file using the Extract Peaks Option.  This creates a new 

spreadsheet or table with extracted peaks.  There will be many shoulder peaks 

from the initial scan file and it is necessary to Refine and Filter the Peaks to 

obtain a final peak file.  Use the Refine Peaks Option to filter out shoulder 

peaks. 

Refine Peaks 

    

   This option removes adjacent shoulder peaks from the peak file.  Specify a 

range for adjacent peaks and all adjacent peaks within this range will be deleted.  
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Use the recommended values if you are unsure which values to use.  Typically, 

extracting peaks is a two part process.  Peaks are first extracted from the scan 

file using the Extract Peaks Option to extract peaks above a specified 

background value.  This creates a new spreadsheet with extracted peaks.  

There will be many adjacent shoulder peaks from the initial scan file and it is 

necessary to Refine and Filter the Peaks to obtain a final peak file.  Use the 

Refine Peaks Option to filter out adjacent shoulder peaks. 
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File Formats 

 

File Formats 

 

   MinSpectra can import the following digital scan files: 

 

MinSpectra *.msp 

Tab Delimited ASCII Type .txt 

Text Files *.txt, *.dat 

USGS Spectra Library V4a *.spc 

USGS Spectra Library V5a *.asc 

John Hopkins University Spectral Library *.txt  

 

   The built in spreadsheet reads and writes data files in tab delimited ASCII 

format. This format is used by Microsoft Excel and is compatible with most 

spreadsheets. To import a data file created with another application, save the 

file in tab delimited format (in Excel, these files have a .txt extension) , start 

MinSpectra and open the data file. MinSpectra will automatically load the file into 

the spreadsheet. To export a data file created with MinSpectra, use any of the 

following methods: 

 

1. Select tab delimited ASCII format in the other application. These files 

usually have a .txt extension. Open the file. 

2. In Excel, the file created with MinSpectra can simply be opened directly. 

The built in spreadsheet requires data to be in a specific format for plotting and 

converting. The first row in the spreadsheet is reserved for column headings. 

Any data placed in the first row will not be included in subsequent calculations. 

Imported data files will be displayed intact with all headings and data; however, 

to use MinSpectra’s features it is necessary to correctly define which columns 

contain wavelength and reflectance with the Define Columns command.  

 

   Additional data can be entered via the keyboard or using the clipboard. 

Other text files can be imported using the Import Text Files Command in the File 

Menu. Several options are displayed. See Import Text Files for more 

information. 
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MinSpectra Files 

 

   MinSpectra Data Files Have the Following Format: 

 

Line 1: “MinSpectra File” 

Line 2: Date 

Line 3: Radiation 

Line 4: Mineral Name 

Line 5: Column Headings 

Line 6 to End: Data 

 

   MinSpectra Files opened within MinSpectra load data and column headings 

only into the spreadsheet. 

 

USGS Spectra Library 4a and 5a 

 

   USGS spectral library 4a and 5a are also supplied. Spectra library 4a is 

supplied with each mineral consisting of two files: 1: A heading file (*.txt) 

containing file information and 2: a data file (*.spc) containing the spectral data. 

The data files can be loaded directly into MinSpectra. 

 

   The data files (*.spc) have the following format: 

 

Line 1: Headings 

Line 2 to End: Data 

 

The USGS spectra 4a data files contain inconsistent data. The inconsistent data 

have the following characteristics: 

Very Large Numbers to Exponent 34. These rows should be deleted and the 

altered file saved. MinSpectra will automatically compensate for the inconsistent 

data if a USGS *.spc file is plotted. 

USGS spectra library 5a consists of 2000 spectra of natural and man made 

materials for remote sensing image interpretation. Spectra 5a library consists of 

asci text files (*.asc) that can be loaded directly into MinSpectra. Files can also 

be downloaded from the USGS Spectroscopy Website. 
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John Hopkins University (ASU) Spectral Library 

 

   MinSpectra can be used with the John Hopkins University (JHU) spectral 

database, supplied as text files that can be loaded directly into MinSpectra’s 

spreadsheet. 

 

   The JHU Spectra Library File is in the Following Format: 

 

Line 1 to Line 26: File headings containing descriptions and identification 

information 

Line 27 to End: Data 

 

   The John Hopkins University Spectral Library contains data for minerals, water 

and ice, vegetation, soils, lunar, meteorites and man made materials. 

With the exception of manmade materials, all spectra in the Johns Hopkins 

Library were measured under the direction of John W. (Jack) Salisbury. Most 

measurements were made by Dana M. D'Aria, either at Johns Hopkins 

University in Ballimore, MD, or at the U.S. Geological Survey in Retsina, VA. 

 

Arizona State University (ASU) Spectral Library for Rock Forming Minerals 

 

   MinSpectra can be used with the Arizona State University (ASU) rock forming 

minerals spectral database, supplied as a text file (asuminerals.txt) that can be 

loaded directly into MinSpectra’s spreadsheet. 

 

   The ASU Rock Forming Minerals Spectra Library File is in the Following 

Format: 

 

Line 1: Column Headings, Column 1: Wavelength Data, Column2 to End: 

Mineral Names 

Line 2 to End: Data 
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   Plots created with MinSpectra can be saved as graphics files for exporting into 

paint programs, word processors and other applications. Graphs can be saved 

in the following formats: 

 

1. bitmap (*.bmp) 

 

Select Save Spectra As from the plot menu and enter the filename with the 

appropriate graphics extension. 

mins3dmb.htm
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Spectral Libraries 

 

   There are several Mineral Spectra Libraries on the internet for use with 

mineral spectral analysis programs. The USGS publishes Mineral Spectral 

Library 4a and 5a. Jet Propulsion Laboratory publishes the Aster Spectral 

Library containing over 2000 minerals. Arizona State University publishes a 

Rock Forming Minerals Spectral Library. See the References section for 

detailed references. The spectral libraries are generally supplied in text files but 

may require further formatting to be compatible with spectral analysis programs. 

Several commercial companies manufacture Infra-Red Spectrometers and 

generally supply software and databases with their instruments. Integrated 

Spectronics manufacture the PIMA field spectrometer. Spectro Analytical also 

manufacture a portable spectrometer. 

 

Arizona State University Spectral Library, http://tes.asu.edu/speclib/ 

 

Christensen, P. R., J. L. Bandfield, V. E. Hamilton, D. A. Howard, M. D. Lane, J. 

L. Piatek, S. W. Ruff, and W. L. Stefanov, A thermal emission spectral library of 

rock-forming minerals, J. Geophys. Res., 105, 9735-9739, 2000. 

 

JPL Spectral Library, http://speclib.jpl.nasa.gov/ 

 

Integrated Spectronics, Pima Field Spectrometer and Spectral Library, 

http://www.intspec.com/ 

 

R. N. Clark, G. A. Swayze, R. Wise, K. E. Livo, T. M. Hoefen, R. F. Kokaly, and 

S. J. Sutley, 2003, USGS Digital Spectral Library splib05a, U.S. Geological 

Survey, Open File Report 03-395 

 

Spectro Analytical, http://www.spectro-ai.com/ 
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